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[bookmark: _Toc936675]Microsoft Excel 2016
Basic Authoring and Testing Guide
[bookmark: _Toc936676]Document Formatting
[bookmark: _Toc527388644][bookmark: _Toc936677]Is the file name descriptive, and is the file in .xlsx format?
How to test
Instruction: Look at the filename in Windows Explorer or the title bar in MS Excel. An example of a descriptive filename is “FundingBudget.xlsx.” The file must be in the “*.xlsx” format for accessibility testing to be possible.
NOTE: If the document extension is not displayed, open your documents folder in Windows Explorer, select “View”>check “File name extensions.”
[bookmark: _Toc527388580][bookmark: _Toc936753]Figure 1: The Save As dialog window
[image: ]
Test A: Is the file name descriptive and does it identify the document or its purpose? If not, the document fails this test.
Test B: Is the file in “Excel Workbook (.xlsx)” format? If not, the document fails this test.
How to author for accessibility
A descriptive file name identifying the document or its purpose helps everyone (including people with disabilities) locate, open, and switch between documents. In addition, the document must be in a “.xlsx” format because these authoring and testing instructions will only work if the file is in the “.xlsx” file format.
Select “File tab>Save As”
Save as type: “Excel Workbook (*.xlsx)”
Save the document with a descriptive file name.
[bookmark: _Toc527388645][bookmark: _Toc936678]Text Formatting
[bookmark: _Toc936679]Are built-in features used to organize content?
How to test
Test A: Does each sheet have a visual and/or logical reading order, left to right then top to bottom? If not, it fails this test.
Test B: Can the sheet be navigated using the up, down, right or left arrow keys, and does it match the visual/logical reading order? If not, it fails this test.
How to author for accessibility
To create a worksheet with logical reading order content:
Start all worksheets in cell A1
Do not span content over multiple rows or columns.
[bookmark: _Toc527388581][bookmark: _Toc527388647][bookmark: _Toc936754]Figure 2: Example of Excel Worksheet with logical reading order
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[bookmark: _Toc527388650][bookmark: _Toc936680]Are link names descriptive?
How to test
Instruction: Find hyperlinks within a worksheet
Test: Do links have meaningful names that describe their destination, function, and/or purpose OR are these determinable within context? If not, the document fails this test.
Uniquely Named Link:
	www.section508.gov
Link Determinable within context:
	Get My Section 508 Questions Answered
An unclear link name with no context:
	click here
How to author for accessibility
Assistive technology users rely on meaningful names to determine the destination, function, or purpose of links. For example, multiple “click here” links are confusing to assistive technology users because the name for each link is the same, while the destinations may be different.
[bookmark: _Toc527388585][bookmark: _Toc936755]Figure 3: Insert Hyperlink configuration window
[image: ]
Naming and creating links:
To edit the name of a link, select the cell containing the hyperlink. Edit the text in the Formula Bar. 
To create a hyperlink, select the cell for the hyperlink and either use the Hyperlink button on the "Insert" ribbon menu or “Ctrl+K” to open the Insert Hyperlink configuration window. Specify the Text to display and the Address for the link and its destination.
[bookmark: _Toc527388651][bookmark: _Toc936681]Object Formatting
[bookmark: _Toc527388652][bookmark: _Toc527388653][bookmark: _Toc936682]Is vital information in headers, footers, and watermarks duplicated in the worksheet?
How to test
Instruction: Look for vital information in headers, footers, and watermarks (e.g. Respond by X date, CONFIDENTIAL, or Do Not Distribute). Note: Watermarks in Excel are floating objects, and cannot be made accessible.
Test: Is the vital information duplicated in the first cell of the worksheet? If not, the document fails this test.
[bookmark: _Toc527388586][bookmark: _Toc936756]Figure 4: Example of vital information repeated in cell A1 of the worksheet
[image: ]
How to author for accessibility
Assistive technology does not automatically read information in headers, footers, and watermarks, so you need to duplicate any vital information in cell A1.
[bookmark: _Toc936683]Did you use built-in features to create data tables?
How to test
Instruction 1: Select a table (“Home>Editing>Find & Select>Go To”). Select any table listed in the “Go To” options window. Note: Images of tables will never be listed in the “Go To” options window.
Test A: Does a “Table Name” display under the “Table Tools>Design>Properties” group? If not, the document fails this test
[bookmark: _Toc936757]Figure 5: Table Properties group displaying Table Name
[image: ]
Instruction 2: Place your cursor on the first row and/or column of a table cell and see if the worksheet has identified the header row and/or column.
Test B: Are “Header Row” and/or “First Column” in the “Table Style Options” group checked? If not, the document fails this test. 
[bookmark: _Toc936758]Figure 6: Header Row and First Column checked in the Table Style Options group
[image: ]
Instruction 3: Select a table. If the Ribbon shows “Picture Tools” tab, instead of the “Table Tools” tab, then the table is an image.
Test C: Is the worksheet free of pictures of tables? If not, the document fails this test.
[bookmark: _Toc936759]Figure 7: Image of data table showing “Picture Tools>Format” tab when selected
[image: ]
How to author for accessibility
Assistive technology users need to be able to identify column headers in data tables to understand the association between table cells and their respective headers.
To create an accessible data table you Select “Insert>Table.”
1. In the create table pane, choose the range of cells for your data table.
2. Check the “My table has headers” checkbox in the create table pane.
3. Choose any cell and name your table “Table Tools>Design>Table Name.”
4. Choose the first cell in the header column and/or row, and update the column and/or row headings with descriptive names.
How to test
[bookmark: _Toc527388587][bookmark: _Toc936760]Figure 8: Image of data table showing “Picture Tools>Format” tab when selected
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[bookmark: _Toc936684]Do images and other objects have alternative text
How to test
Instruction 1: Examine cells surrounding a non-text element for text describing the object or its purpose/meaning. 
Test A: Does the image/object/shape/chart or other non-text element have descriptive text or is there an appendix for all non-text elements? If not, the document fails this test.
How to author for accessibility
In Excel images, objects, shapes, charts and other non-text elements cannot be anchored/embedded in a cell. Screen reader users cannot access the alt-text of floating elements. Therefore, you must add descriptive text to images and other objects by adding information in a cell near the object, or list the non-text elements and their descriptions in a separate appendix. 
[bookmark: _Toc527388655][bookmark: _Toc936685]Color Formatting
[bookmark: _Toc527388656][bookmark: _Toc936686]Are colors and other visual characteristics that convey information (such as size, shape, and location) also described in text?
How to test
Using only color or other visual characteristics to convey meaning will not provide comparable access to people who are blind, have low vision, or are colorblind.
Instruction: Find where you have used color and/or other visual characteristics to convey meaning such as green, yellow, red, etc.
Test: Is there text that conveys the meaning of the color or other visual characteristics? If not, the document fails this test.
How to author for accessibility
The following layout tables describe the progress for three projects using colors to symbolize the current project status. Adding text in addition to the color provides comparable information to users of assistive technology and people who are colorblind.
Use text to duplicate the meaning of the color or visual characteristics (such as size, shape, and location).
[bookmark: _Toc527112484][bookmark: _Toc936762]Table 1: Examples of a project status table using only color and color with text
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	Project
	Status

	Project A
	

	Project B
	

	Project C
	



	Project
	Status

	Project A
	On Time

	Project B
	At Risk

	Project C
	Late


[bookmark: _Toc524350350][bookmark: _Toc527388657]
[bookmark: _Toc936687]Is the contrast ratio between text and background sufficient?
NOTE: If the document text is black on white background (or close to it), you do not need to perform this test. This test requires the Colour Contrast Analyser (an external application).
How to test
Execute the Colour Contrast Analyser. Select “Download” (the application can be executed without downloading it onto your computer). Open the Colour Contrast Analyser. Drag the “Foreground eyedropper” icon over a sample of your text or image of text. Drag the “Background eyedropper” icon over a sample of your background color.
Test: Have you formatted with the correct color contrast ratio? If not, the document fails this test.
[bookmark: _Toc524349989][bookmark: _Toc527388592][bookmark: _Toc936761]Figure 9: Examples of pass and fail results with the Colour Contrast Analyser
[image: ]
How to author for accessibility
People who are colorblind or have low vision will have comparable access if there is sufficient contrast between the text and the background. The contrast standards are:
[bookmark: _Toc527112485][bookmark: _Toc936763]Table 2: Table with contrast ratios for types and sizes of text
	Type or Size of Text
	Contrast Ratio

	Standard text (12 pt regular)
	4.5:1

	Large Text (14 pt bold or 18 pt regular)
	3:1

	Incidental text, text overlaid on images, and logotypes
	Excluded from requirement



[bookmark: _Toc527112486]Create content with text or images of text that use color or shading with sufficient color contrast. If the contrast ratio does not pass, then adjust your foreground or background until it does pass.
[bookmark: _Toc936764]Table 3: Examples of good and insufficient color contrast ratios
	Good Color Contrast
	Insufficient Color Contrast

	White text on 
black background 
ratio 21:0:1
	Dark gray text on 
black background
ratio 3.0:1

	Dark green text 
on yellow background
ratio 7.6:1
	Orange text on 
yellow background
ratio: 2.1:1

	Light blue text on 
dark blue background
ratio: 10.5:1
	Red text on 
dark blue background
ratio: 1.1:1

	white text on 
red background
ratio: 6.5:1
	Dark green text on 
red background 
ratio: 1.3:1


[bookmark: _Toc527388658][bookmark: _Toc936688]Miscellaneous
[bookmark: _Toc527388659][bookmark: _Toc936689]Are descriptions of embedded audio, video and multimedia files accurate?
How to test
NOTE: If the document does not contain audio, video, or multimedia files, you do not need to perform this test.
Instruction: Activate the audio-only, video-only, or multimedia file.
Test A: Is there an accurate and complete text transcript for multimedia files, text description for audio files, and synchronized caption and/or audio description for video files? If not, the document fails this test.
How to author for accessibility
If you embed an audio-only, video-only, or multimedia file that contains meaningful information into your MS Excel Workbook, you must also provide additional information so that individuals with disabilities have comparable access to the information.
Audio-only
Accurate and complete transcript
Video-only
Accurate and complete text description
Multimedia (audio and video)
Accurate and complete synchronized captions and audio descriptions
[bookmark: _Toc527388660][bookmark: _Toc936690]Did you exclude flashing objects?
How to test
Test: Is the document free of all flashing objects? If not, the document fails this test.
How to author for accessibility
Create your content without using flashing objects. Flashing objects can cause seizures and should never be used.
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